wiki:InstallingAmaraWithoutEasyInstall

If using easy_install to install Amara 1.2.0.2 and its dependencies fails, the following might be useful:

Search for and download Amara-1.2.0.2.tar.gz, 4Suite-XML-1.0.2.tar.gz, python-dateutil-1.5.tar.gz to $CHASTE_LIBS

cd $CHASTE_LIBS 
mkdir python
export PYTHONPATH=$PYTHONPATH:$CHASTE_LIBS/python
wget http://peak.telecommunity.com/dist/ez_setup.py
python ez_setup.py -U setuptools
tar xvfz python-dateutil-1.5.tar.gz
cd python-dateutil-1.5
python setup.py install
cd ..
tar xvfz 4Suite-XML-1.0.2.tar.gz 
cd 4Suite-XML-1.0.2
python setup.py install --prefix=$CHASTE_LIBS/python
cd ..
tar xvfz Amara-1.2.0.2.tar.gz 
cd Amara-1.2.0.2
python setup.py install --prefix=$CHASTE_LIBS/python
cd ..
Last modified 8 years ago Last modified on Jun 4, 2012, 4:02:53 PM