Change History for InstallGuides/DependencyVersions

Version Date Author Comment
193 4 weeks GaryM #3047 PETSc 3.14 support to be added
192 7 weeks fcooper Update PETSc 3.11.3 and 3.12
191 7 weeks GaryM Point out the problem with PETSc 3.11.3 at the moment.
190 7 weeks fcooper Update tested boost versions
189 5 months fcooper Updated untested dependencies
188 7 months GaryM Support for PETSc 3.12 and 3.13 to be added
187 13 months fcooper Update VTK 8.2 to tested
186 13 months GaryM I've got a build on gcc 7.4 (although problems with AggressiveOpt?!)
185 13 months GaryM make ones that were deprecated in previous release red now.
184 14 months GaryM #2984 and #2994
183 15 months GaryM Sundials 5.0.0
182 15 months GaryM C++14
181 17 months fcooper PETSc 3.11 now tested
180 18 months fcooper PETSc 3.7 preferred; 3.10 tested
179 18 months fcooper Add tickets for new HDF5 versions
178 18 months fcooper Update HDF5
177 18 months fcooper
176 18 months fcooper Updated boost 1.65.1 to preferred - this is default on Ubuntu 18.04 …
175 18 months fcooper Boost 1.70 and Xerces 3.2.2 are in rotation and tested
174 18 months fcooper Update Xerces: < 3.1.3 no longer officially supported, and 3.2.0 is …
173 18 months fcooper Add Xerces 3.2.2
172 18 months GaryM perhaps for cmake 3.12 and 3.13 - or are they on any build machines?
171 18 months GaryM
170 19 months GaryM #2998 Boost 1.70
169 19 months GaryM #2997 PETSc 3.11 support
168 21 months GaryM #2994 sundials 4.1.0 support
167 22 months GaryM Link to Python 3 ticket
166 22 months GaryM #2983 boost 1.69 in regular rotation.
165 22 months GaryM Tidy redundant footnotes
164 22 months GaryM Tidy footnotes
163 22 months GaryM Boost 1.68 works, not regular test
162 23 months GaryM Drop all deprecated dependencies that were last supported in 2018.1
161 23 months GaryM new dependencies
160 23 months GaryM CMake 3.12
159 2 years GaryM #2974 PETSc 3.10 and #2975 Boost 1.68
158 2 years GaryM Mark some dependencies as deprecated (will work in this release but …
157 2 years GaryM Add 1.65.1 to the table which seems to work in new Ubuntu 18.04.
156 2 years GaryM scons 3.0.1 with Ubuntu 18.04 seems to 'just work'
155 2 years fcooper Updated build and compiler info
154 2 years fcooper Update Xerces 3.1.3 to preferred and 3.1.2 to tested
153 2 years fcooper Updated now-tested Xerces 3.2.0 and 3.2.1
152 2 years fcooper Updated xerces libs to be added
151 2 years fcooper Updated now-tested dependencies (petsc 3.8 and hdf5 1.8.20) to light green
150 2 years fcooper Add ticket number for VTK 8.1
149 2 years fcooper Updated now-tested dependences (petsc 3.9, hdf5 1.10.2, vtk 8.1) to …
148 2 years fcooper Add ticket numbers
147 2 years fcooper Add more tobeadded libraries, which need tickets opening
146 3 years GaryM #2954 PETSc 3.9
145 3 years fcooper Added Xerces 3.2.x as tobeadded
144 3 years GaryM #2949 PETSc 3.8
143 3 years GaryM Boost 1.66 and CVODE 3.1 in the mix
142 3 years GaryM Note on CVODE version number - now in sync
141 3 years GaryM CVODE 3.0.0 and 3.1.0 should work #2937
140 3 years GaryM Boost 1.66 should work now.
139 3 years GaryM CVODE 3.1.0
138 3 years GaryM Turn purple dependencies in release 2017.1 to red.
137 3 years GaryM #2945 Boost 1.66
136 3 years GaryM Sundials AND CVODE 3.0.0
135 3 years fcooper
134 3 years fcooper Updated information on supported compiler versions
133 3 years GaryM #2893 boost 1.65 broken on cmake, works with scons
132 3 years fcooper Changed colour of VTK 8.0 and CMake 3.9 now that they are tested in …
131 3 years fcooper Updated table with more sensible values for CMake
130 3 years fcooper Added footnote for VTK 8 about CMake 3.3 minimum requirement
129 3 years fcooper Swapped colours for boost 1.63 and boost 1.65 after changing lofty rotation
128 3 years GaryM
127 3 years GaryM #2893 Boost 1.64 and 1.65
126 3 years fcooper Add boost 1.65
125 3 years fcooper
124 3 years fcooper
123 3 years fcooper Updated dependency colours to reflect current testing rotations
122 4 years GaryM #2893 Boost 1.64 to be added
121 4 years fcooper
120 4 years fcooper
119 4 years fcooper
118 4 years fcooper
117 4 years fcooper
116 4 years fcooper
115 4 years fcooper
114 4 years fcooper
113 4 years fcooper
112 4 years fcooper
111 4 years fcooper
110 4 years fcooper
109 4 years fcooper
108 4 years fcooper
107 4 years fcooper
106 4 years fcooper
105 4 years fcooper
104 4 years fcooper
103 4 years fcooper
102 4 years fcooper
101 4 years fcooper
100 4 years GaryM #2805 we dropped HDF5 1.6 support
99 4 years GaryM #2872 - Boost 1.63
98 4 years GaryM #2853 new boosts seem to pass all tests
97 4 years GaryM #2854 CVODE 2.9.0 seems to work (not in testing rotation yet)
96 4 years GaryM #2854
95 4 years GaryM #2853
94 4 years GaryM Deprecate the ones we said we would after Release 3.4
93 4 years jonc@… #2804 PETSc 3.7 in lofty rotation
92 4 years jonc@…
91 4 years jonc@… Work in progress on #2804
90 4 years jonc@… Add a footnote about the r26665 issue
89 4 years jonc@… Updated tested versions per r26594.
88 5 years jonc@… HDF5 1.6 will not be supported in future releases
87 5 years louiecn Recent HDF5 versions
86 5 years GaryM #2804 PETSc 3.7
85 5 years GaryM
84 5 years GaryM Deprecating all boosts up to and including 1.47, supported now but not …
83 5 years GaryM #2765 Boost 1.60 works
82 5 years GaryM #2765
81 5 years jonc@… #2747 support for scons 2.4, and other updates
80 5 years GaryM #2747 - scons 2.4.0
79 5 years GaryM #2688
78 5 years jmpf@… #2688 : should now work, but not in the robert/lofty mix.
77 5 years GaryM #2726 Boost 1.59
76 5 years GaryM Testing 1.59 instead of 1.49 now
75 5 years GaryM #2726 Boost 1.59
74 5 years GaryM #2688 PETSc 3.6
73 5 years GaryM #2678 we will test 1.58.
72 5 years GaryM Boost 1.40 (August 2009) went out with Ubuntu 10.04LTS, so drop next.
71 5 years GaryM Ticket #2674 should work
70 6 years jonc@… Update HDF5 testing record
69 6 years jonc@… #2678 Boost 1.58 looks ok
68 6 years GaryM #2678
67 6 years GaryM formatting comment
66 6 years GaryM #2674
65 6 years jonc@… We'll stop testing PETSc 2 soon
64 6 years GaryM #2585
63 6 years jonc@…
62 6 years jonc@… Update colours to match latest lofty as of r23339
61 6 years jonc@…
60 6 years GaryM #2626
59 6 years jonc@… Add links to some tickets where support for particular versions was …
58 6 years GaryM maybe
57 6 years GaryM Bad boosts
56 6 years GaryM #2628 XSD
55 6 years GaryM
54 6 years GaryM Boost 1.57
53 6 years louiecn Change "might work" to "should work". Also make HDF5 1.8.13 this.
52 6 years jonc@… #2599
51 6 years GaryM #2585
50 6 years GaryM Petsc 3.5
49 6 years jonc@…
48 6 years GaryM No longer support older boosts now the release has happened.
47 6 years louiecn Hint about checking multipleversions page for answers.
46 6 years louiecn HDF5 1.8.11 works fine for me
45 6 years louiecn Bit of editing
44 6 years jonc@… #2469 done, and note newer versions of some dependencies available but …
43 6 years louiecn #2469 5.10 tested, 6.0 and 6.1 soon
42 7 years GaryM Oldest LTS Ubuntu now has boost 1.40, drop older ones after release 3.2
41 7 years jonc@… Just tested Boost 1.55 on Linux - continuous tests pass
40 7 years GaryM #2469 VTK 6
39 7 years GaryM Boost 1.55
38 7 years jonc@…
37 7 years jmpf@…
36 7 years jmpf@… #2385/#2406 new PETSc and Boost
35 7 years jmpf@… #2345 - Boost 1.53 isn't in lofty builds (but 1.54 will be)
34 7 years GaryM boost 1.54
33 7 years GaryM #2385 - PETSc 3.4
32 8 years GaryM #2377
31 8 years jmpf@… #2130 PETSc 3.3 (and parMETIS)
30 8 years jmpf@… parMETIS 4.* is now a perhaps (at least!)
29 8 years GaryM VTK 5.10.1 seems to work, but isn't regularly tested yet.
28 8 years GaryM Add a couple more categories
27 8 years GaryM
26 8 years GaryM #2345 boost 1.53 is a perhaps
25 8 years jonc@… Update to use new macro, and add more detailed info (#2322)
24 8 years jonc@… #2250
23 8 years GaryM Good spot John
22 8 years jonc@… We can cope with very old scons (this is used on chaste-bob)
21 8 years GaryM scons versions
20 8 years GaryM until I get this working…
19 8 years GaryM new VTK
18 8 years GaryM dropping 5.04 since new compilers don't like it.
17 8 years GaryM Amara
16 8 years GaryM new HDF5s - don't know if they will work yet
15 8 years GaryM xerces
14 8 years jmpf@… Colours work better in colour
13 8 years GaryM
12 8 years GaryM scons
11 8 years rafb@… vtk 5.6 and hdf5 1.6.6
10 8 years GaryM
9 8 years GaryM a couple more…
8 8 years GaryM
7 8 years GaryM
6 8 years GaryM
5 8 years GaryM
4 8 years GaryM
3 8 years GaryM a few more started.
2 8 years GaryM key
1 8 years GaryM New guide to supported dependencies?