Changes between Version 191 and Version 192 of InstallGuides/DependencyVersions


Ignore:
Timestamp:
Sep 10, 2020, 6:13:34 PM (7 weeks ago)
Author:
fcooper
Comment:

Update PETSc 3.11.3 and 3.12

Legend:

Unmodified
Added
Removed
Modified
  • InstallGuides/DependencyVersions

    v191 v192  
    5151no=red, tested=yellowgreen, yes=green, perhaps=orange, notforlong=purple, tobeadded=lightblue
    5252|| Library ||* Versions ||
    53 || PETSc || no <= [ticket:2565 3.5] || yes [ticket:2688 3.6] || yes [ticket:2804 3.7] || tested [ticket:2949 3.8] || tested [ticket:2954 3.9] || tested [ticket:2974 3.10] || tested [ticket:2997 3.11.1] || no [ticket:3021 3.11.3] || tobeadded [ticket:3028 3.12] || tobeadded [ticket:3029 3.13] ||
     53|| PETSc || no <= [ticket:2565 3.5] || yes [ticket:2688 3.6] || yes [ticket:2804 3.7] || tested [ticket:2949 3.8] || tested [ticket:2954 3.9] || tested [ticket:2974 3.10] || tested [ticket:2997 3.11.1] || tested [ticket:3021 3.11.3] [#fn3 ~] || yes [ticket:3028 3.12] [#fn3 ~] || tobeadded [ticket:3029 3.13] ||
    5454|| Boost || no <= [ticket:2626 1.57] || yes [ticket:2678 1.58] || perhaps [ticket:2726 1.59] || tested [ticket:2765 1.60] || tested [ticket:2853 1.61] || tested [ticket:2853 1.62] || perhaps [ticket:2872 1.63] || perhaps [ticket:2893 1.64] [#fn2 #] || no [ticket:2893 1.65] || yes [ticket:2893 1.65.1] || tested [ticket:2945 1.66] || tested [ticket:2960 1.67] || perhaps [ticket:2975 1.68] || tested [ticket:2983 1.69] || tested [ticket:2998 1.70] || yes [ticket:3038 1.71] || tested [ticket:3038 1.72] || tested [ticket:3038 1.73] || tested [ticket:3038 1.74] ||
    5555|| parMETIS || no <= 3.1 || yes [ticket:2250 4.*]  ||
     
    7070`#` Boost 1.64 has a bug in serialization that means it needs patching before use in Chaste, otherwise it breaks compilation, so it is not recommended if you can avoid it. See #2893 for details.
    7171
     72[[Anchor(fn3)]]
     73`~` A temporary fix is keeping PETSc > 3.11.1 compatible with Chaste. See #3040 for details.
     74
    7275Note: some versions of dependencies have quirks that may not be documented on this wiki, but you may find hints on the [InstallGuides/TestingMultipleVersions testing multiple versions] page. For example, building with VTK 5.10 requires changes to your hostconfig since it names its libraries differently to the other 5.x versions.