wiki:InstallGuides/DependencyVersions

Supported versions of our dependencies

Chaste has a number of dependencies. If you are using the Ubuntu package then the best versions are selected and installed automatically for you.

If you are doing a manual linux installation, then this page shows you the supported and preferred versions of each dependency. Note that it reflects the status of the current trunk code, rather than previous releases of Chaste; see instead the copy of this page associated with a release for that information.

The main install guide should generally be updated to reflect installation instructions for one of the preferred versions.

Key to table:

  • Red -- Not compatible/supported. Either because these versions have bugs, or are deprecated because they don't do everything we need now, or are too old to continue tested support for.
  • Purple -- To be dropped. This version will work with the current release, and perhaps/probably/parts-of the development version, but will not be supported in future releases.
  • Blue -- Not yet supported. We plan to support these, this may just mean we have not yet had the chance to test them for compatibility and adapt the code for them if needed.
  • Orange -- Should work. These are expected to work, we've generally tested them at least once, but these versions are not regularly tested with the development code.
  • Light green -- Supported. These are versions that we test against regularly and so should pass all standard tests, but are not our recommended versions. They might have small bugs or not have as many features, or won't be supported for as long (e.g. not the default in an Ubuntu LTS).
  • Green -- Preferred versions. No known problems, we regularly test these and intend to maintain Chaste compatibility for as long as practical (usually longer than the package developers).

Build systems

Preferred CMake versions are those that are default on Ubuntu LTS releases, but we expect every version of CMake above the minimum required to work fine.

Build systemVersions
cmake< 3.43.53.63.73.83.93.103.123.13
scons<= 2.3.*2.4.*2.5.*3.0.1

Compilers

Preferred compiler versions are the default versions of GCC and Clang on Ubuntu LTS releases, and specific versions of the Intel compiler that we regularly test Chaste with. We expect all other C++14-capable versions of GCC, Clang and Intel to compile Chaste with no problems.

CompilerVersions
clang< 3.33.33.43.53.63.73.83.94.05.06.0
gcc< 5.35.46.16.26.36.47.17.27.37.4
intel< 1515161718
msvc??

Dependencies

In some instances the version number is a link to the ticket in which support was/is being introduced.

The strikethrough formatting means the ticket has been closed, usually successfully, it does NOT mean the version is unsupported!

LibraryVersions
PETSc<= 3.53.63.73.83.93.103.11.13.11.3 ~3.12 ~3.13
Boost<= 1.571.581.591.601.611.621.631.64 #1.651.65.11.661.671.681.691.701.711.721.731.74
parMETIS<= 3.14.*
HDF5<= 1.8.151.8.161.8.17-201.8.211.10.01.10.11.10.21.10.31.10.41.10.51.10.61.12.0
XSD<= 3.34.0.0
Xerces<= 3.1.23.1.33.1.43.2.03.2.13.2.23.2.3
Amara1.2.0.22.*
SUNDIALS<= 2.4.0 2.5.02.6.02.7.03.0.03.1.04.0.04.1.05.0.05.15.25.3
VTK<= 6.16.26.37.07.18.08.18.29.0
python< 2.02.*3.*

Footnotes:

SUNDIALS prior to 3.0.0 includes CVODE with a different version number, usually + 0.2 !

# Boost 1.64 has a bug in serialization that means it needs patching before use in Chaste, otherwise it breaks compilation, so it is not recommended if you can avoid it. See #2893 for details.

~ A temporary fix is keeping PETSc > 3.11.1 compatible with Chaste. See #3040 for details.

Note: some versions of dependencies have quirks that may not be documented on this wiki, but you may find hints on the testing multiple versions page. For example, building with VTK 5.10 requires changes to your hostconfig since it names its libraries differently to the other 5.x versions.

Last modified 2 weeks ago Last modified on Sep 10, 2020, 6:13:34 PM