#3003 closed user story (fixed)

Support HDF5 1.8.21, 1.10.3, 1.10.4, 1.10.5

Reported by: fcooper Owned by:
Priority: high Milestone: Future
Component: infrastructure Keywords: HDF5
Cc: GaryM Estimated pair-hours remaining: 0
Pair-hours expended on ticket: 3 Initial estimate of effort: 3
Editable by public: yes

Description

  • Compile on Lofty
  • Add to rotation
  • Update dependency versions matrix

Change History (2)

comment:1 Changed 18 months ago by fcooper

The full range of HDF5 is currently:

1.8.16 through to 1.8.21

and

1.10.0 through to 1.10.5

This is too many versions to be testing all of them, particularly as we test specific combinations of HDF5 with PETSc.

I think a sensible plan is to have 1.8.16 and 1.10.0 as our dark green preferred versions, as these are the defaults on Ubuntu 16.04 and 18.04.

I suggest we then test against the newest 1.8, and focus on testing the newer 1.10s, which certainly seems to be the HDF5 development focus at present.

comment:2 Changed 18 months ago by fcooper

  • Resolution set to fixed
  • Status changed from new to closed

All of the new versions are now compiled on Lofty and in the rotation.

I have put 1.8.17 - 1.8.20 orange as they are no longer regularly tested, but should work (and have been regularly tested in the past).

Note: See TracTickets for help on using tickets.