Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#2674 closed user story (fixed)

Support Cvode 2.8.0

Reported by: GaryM Owned by:
Priority: normal Milestone: Iteration I3
Component: infrastructure Keywords:
Cc: Estimated pair-hours remaining: 0
Pair-hours expended on ticket: 1.6 Initial estimate of effort: 2
Editable by public: yes

Description

Got an e-mail telling me there's a new version of sundials out https://computation.llnl.gov/casc/sundials/download/whatsnew.html

Change History (4)

comment:1 Changed 6 years ago by jonc@…

Doesn't look like there's anything there to cause us problems!

comment:2 Changed 6 years ago by GaryM

I just gave this a try (r24120 on travis). N.B. They immediately upgraded to 2.8.1

The only installation route is now cmake, so the install route we have on InstallGuides/TestingMultipleVersions will have to change.

The only problem we have is that sundials_config.h ends up with a line:

#define SUNDIALS_PACKAGE_VERSION 2.6.0

(even in version 2.6.1 - but that's not the problem!), the problem is that it is no longer in quotes i.e it used to look like:

#define SUNDIALS_PACKAGE_VERSION "2.5.0"

Which I modified the hostconfig to read by changing

version_re = re.compile(r'#define SUNDIALS_PACKAGE_VERSION "(\d+).(\d+).(\d+)"')

to

version_re = re.compile(r'#define SUNDIALS_PACKAGE_VERSION "{0,1}(\d+).(\d+).(\d+)"{0,1}')

But then you get an exception with

global/src/ExecutableSupport.cpp:382:37: error: too many decimal points in number

because the global variable is now a number not a string.

If I put in a manual hack to make the SUNDIALS_PACKAGE_VERSION behave then it works fine, compiles, runs, and passes all tests.

Last edited 6 years ago by GaryM (previous) (diff)

comment:3 Changed 5 years ago by jonc@…

  • Estimated pair-hours remaining changed from 2 to 0
  • Pair-hours expended on ticket changed from 0 to 1.5
  • Resolution set to fixed
  • Status changed from new to closed

Updated installation notes, enabled building Chaste with CVODE 2.8 in r24130, and fixed a memory issue in r24131 (not sure why we hadn't seen that before - maybe just lofty being more picky than scoop?).

comment:4 Changed 4 years ago by jonc@…

  • Pair-hours expended on ticket changed from 1.5 to 1.6

Added to lofty rotation in r26594.

Note: See TracTickets for help on using tickets.