Opened 6 years ago

Closed 6 years ago

#2626 closed user story (fixed)

Boost 1.57 support

Reported by: GaryM Owned by:
Priority: high Milestone: Iteration I3
Component: infrastructure Keywords:
Cc: Estimated pair-hours remaining: 0
Pair-hours expended on ticket: 2 Initial estimate of effort: 6
Editable by public: yes

Description

Boost versions coming thick and fast. See #2585 for Boost 1.56 support which isn't finished yet.

http://www.boost.org/users/history/version_1_57_0.html

No obvious changes to affect us, but we said that last time too.

Change History (6)

comment:1 Changed 6 years ago by GaryM

More problems occurred when compiling boost include headers (similar to #2585, in fact probably caused by the solution that was implemented for that!). So I reported them to boost serialization project on github again here. This time you need to add

#include <boost/serialization/type_info_implementation.hpp>

to the top of include/boost/serialization/shared_ptr_helper.hpp.

As in #2585, removing a spurious #include in r23048 from a Chaste class has removed one compilation error, but this time (at least) one remains in a class where I couldn't do this. So at present we may have to make boost 1.57 a 'buggy' version to be avoided.

If you do the manual change to the boost include as described then everything compiles fine. But then you get the same 10 tests failing in global, cell_based and crypt that look like they are from a change to random numbers, exactly as per #2585:

cell_based-test-cell-TestSimpleCellCycleModels.1_17.0
crypt-test-cell-TestCellForCrypt.1_4.0
crypt-test-cell-TestOdeBasedCellCycleModelsForCrypt.2_13.1
crypt-test-cell-TestSimpleCellCycleModelsForCrypt.2_3.12
crypt-test-cell-TestSingleOdeWntCellCycleModel.2_3.0
crypt-test-simulation-TestOffLatticeCryptProjectionSimulation.1_2.3
crypt-test-simulation-TestPottsBasedCryptSimulation.1_2.10
crypt-test-statistics-TestCryptProjectionStatistics.1_1.3
global-test-TestArchivingHelperClasses.1_7.0
global-test-TestRandomNumberGenerator.1_10.0

So probably back to that ticket to think about that.

comment:2 Changed 6 years ago by GaryM

Update: the bug has been fixed in the development version of boost, to end up in boost 1.58 - see commit on github. But if you want to use 1.57 you will need to do the manual fix.

comment:3 Changed 6 years ago by GaryM

  • Estimated pair-hours remaining changed from 6 to 0
  • Pair-hours expended on ticket changed from 0 to 2
  • Resolution set to wontfix
  • Status changed from new to closed

The bug should be fixed in the next release of boost. But for now I am going to make a note on InstallGuides/DependencyVersions.

Work on getting the random numbers consistent can continue on #2585.

comment:4 Changed 6 years ago by GaryM

r23168 prevents compilation failure by including the missing include in ChasteSerialization.hpp, this enabled a full build on userpc59 to run. Still got the failing tests due to what looks like random numbers changing.

comment:5 Changed 6 years ago by jonc@…

  • Resolution wontfix deleted
  • Status changed from closed to reopened

We've actually fixed this, so I'm going to change the resolution.

comment:6 Changed 6 years ago by jonc@…

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.